AnsweredAssumed Answered

Upgrade issue - 14.3 patch 10 fails

Question asked by karthik.v on Apr 9, 2018
Latest reply on Apr 9, 2018 by Jon_Israel

Our current CA PPM version: 14.3.0.298 06 7

We are in process of upgrading to 15.4, and one of the first steps is applying patch 10 on our 14.3 install.

We are receiving the following error during the middle of running install.bat for patch 10:

 

 

4/06/18 10:14 AM (ExecTask) Current database version is database_20160422_0545
4/06/18 10:14 AM (ExecTask) DBDriver for database_20170112_1603
4/06/18 10:14 AM (ExecTask) Start installation of DBDriver ...
4/06/18 10:14 AM (ExecTask)
4/06/18 10:14 AM (ExecTask) Note: Foreign Keys have been disabled
4/06/18 10:14 AM (ExecTask)
4/06/18 10:14 AM (ExecTask) DBDriver failed to install!
4/06/18 10:14 AM (ExecTask)
4/06/18 10:14 AM (ExecTask) Total time: 0H:0M:1S
4/06/18 10:14 AM (ExecTask) Exception in thread "main" java.lang.Exception: DBDriver failed to install
4/06/18 10:14 AM (ExecTask) at com.niku.dbtools.DriverApp.installSchemaDriver(DriverApp.java:911)
4/06/18 10:14 AM (ExecTask) at com.niku.dbtools.Utilities.run(Utilities.java:1862)
4/06/18 10:14 AM (ExecTask) at com.niku.dbtools.Utilities.main(Utilities.java:975)
4/06/18 10:14 AM (ExecTask) Caused by: java.sql.SQLSyntaxErrorException: [CA Clarity][SQLServer JDBC Driver][SQLServer]Cannot find the object "Message" because it does not exist or you do not have permissions.

 


Install log is attached.

Note: The user NIKU is a member of DB_OWNER role. Other DB pre-requisites have also been taken care of.

 

 

Has anyone seen this issue before?

Any help in resolving this is greatly appreciated.

 

Thanks!

Attachments

Outcomes