Antoine_Sauteron_1266

Compatibilité des agents avec un serveur Automation Engine de version différente

Discussion created by Antoine_Sauteron_1266 on Dec 21, 2016
Cette question revient très souvent de la part de nos clients.

Le sujet a déjà été abordé, mais voici quelques informations complémentaires à ce propos.

L'Automation Engine est d'une version supérieure à celle de l'agent

Par exemple un agent Windows version 10 avec un Automation Engine version 12

L'Automation Engine est rétro-compatible avec les agents de versions inférieures, et il n'existe pas de limite théorique à cette rétro-compatibilité. Bien sûr nous n'assurons pas le support des agents dont les versions ne sont plus maintenues / supportées (voir ici pour plus de détails), mais il est techniquement possible de continuer à utiliser des agents de versions parfois très anciennes. Certains de nos clients utilisent par exemple des agents version 6 avec un AE version 11.2.

Il existe cependant quelques restrictions:

  • Cela ne s'applique pas aux agents RA, dont le noyau doit être de même version que l'Automation Engine:
https://docs.automic.com/documentation/webhelp/english/ALL/components/RA_WEB_SERVICE/latest/Agent Guide/help_en.htm#RA/WS/LC/Installing_RA_Agents_in_an_Existing_Automation_Engine_System.htm

lfryog4jp8mh.png
  • Les fonctions de script ayant été apportées avec l'arrivée d'une nouvelle version ne fonctionneront pas avec des agents de version antérieure. Par exemple:REGISTER_VARIABLEne marchera pas sur agent antérieur à la v11.2.


L'Automation Engine et l'agent sont de même version, mais l'agent est d'un Service Pack plus récent

Par exemple le serveur AE et l'Agent sont en version 10, mais le serveur est en v10SP3 et vous voulez passer l'agent en version 10 SP8.

Cette configuration est également supportée et doit fonctionner.

L'Automation Engine est d'une version inférieure à celle de l'agent

Par exemple un Agent version 12 avec un Automation Engine version 10

Cela n'est pas supporté et causera les erreurs de connexion suivantes au démarrage de l'agent :

dj9hs3k67i9i.png

Bien évidemment notre recommandation reste d'avoir toujours des agents et un serveur AE en conformité. LA rétro-compatibilité sert avant tout à permettre une phase de transition lors de la montée de version du serveur.

N'hésitez pas à réagir à ce post, le compléter, poser des questions ou partager vos expériences...

Cordialement,
Antoine

Outcomes