Duong_Nguyen-Nhat_2335

When using the Websphere stop cluster action, it shows the password as plain text

Discussion created by Duong_Nguyen-Nhat_2335 on Mar 17, 2017
This has been asked recently:

If you use the Websphere stop cluster action, it shows the password as plain text see attached report. I replaced the password with the value PLAINTEXTPASSWORD in the attached report. 

************************************************************************ 
** ucxja64m version 12.0.0+build.3427 changelist 7854944 ** 
** JOB 01169676 (ProcID:0021430384) START AT 24.02.2017 / 11:45:53 ** 
** UTC TIME 24.02.2017 / 10:45:53 ** 
** TEXT=" Job started " ** 
************************************************************************ 
off 
itpa-tool: itpa-tool 
itpa-tool: (c) Automic Software GmbH 
itpa-tool: Version: 1.2.1 
itpa-tool: Date: 2016-09-13 10:17 

WASX7209I: Connected to process "dmgr" on node dmgrDEVmlNode1 using SOAP connector; The type of process is: DeploymentManager 
WASX7303I: The following options are passed to the scripting environment and are available as arguments that are stored in the argv variable: "[/opt/automic/resources/0100/wsadminlib.py, /opt/automic/resources/0100/pck_websphere_utils.py, /opt/WebSphere64/80/ML/profiles/dmgrDEVml/bin, LOANEECitClus, NO, wasadmin, PLAINTEXTPASSWORD]" 
stopping the cluster member servers 
Current state: websphere.cluster.running 

************************************************************************ 
This is considered as a bug and will be fixed by our DEV-Team, however we do have the workaround as below:

Find wsadmin.properties file in profiles folder of WebSphere installation directory. E.g: profiles/<profile-name>/properties/wsadmin.properties. Then disable showing arguments of script in webphere trace by setting property:

{code:java}
// disable echo parameters of script to WebSphere trace
com.ibm.ws.scripting.echoparams=false
{code}

Outcomes