Java related error when running RMS jobs under Oracle Retail Agent

Discussion created by Jeremy_Cullen_1949 on Jul 19, 2017
Latest reply on Jul 27, 2017 by VindyaSolangarachchi612391
Hi guys,

Wondering if anyone has come across the following error when trying to run jobs (taken from Agent log):
++++++++++++++++++++++++++++++++++ Start of Runtime Exception ++++++++++++++++++++++++++++++++++++ java.lang.ClassCastException: [Ljava.util.ArrayList; cannot be cast to java.util.List      at groovy.lang.MetaClassImpl$2.invoke(      at groovy.lang.MetaMethod.doMethodInvoke(      at groovy.lang.MetaClassImpl.invokeMethod(      at groovy.lang.MetaClassImpl.invokeMethod(      at      at      at RetailJob.runJob(OracleRetailAgent.groovy:1626)      at com.uc4.extensibility.types.CITAgent.dispatchJob(      at com.uc4.ex.cit.CITJob.execute(      at      at com.uc4.ex.ThreadPool$      at java.util.concurrent.Executors$      at      at java.util.concurrent.ThreadPoolExecutor.runWorker(      at java.util.concurrent.ThreadPoolExecutor$      at ++++++++++++++++++++++++++++++++++++++ End of Runtime Exception ++++++++++++++++++++++++++++++++++++++

This occurs when trying to run Oracle RMS jobs via the Oracle Retail Agent  (version 12.0.2+ build 734)
We have tried java 1.7 and 1.8 - same error occurs
Launching jobs from Automic Web Interface 12.0.0.HF03-346

Hoping someone has seen this issue before