Michael_Lowry

U04002032 error when exporting objects to XML

Discussion created by Michael_Lowry on Aug 30, 2017

Today I encountered some theretofore unencountered errors when attempting to export objects to XML. When I tried to export a particular folder, a the following error appeared:

Error: U00020568 Runtime error in object 'FRAGMENT_VARA_STATIC(GET)', line '00022'.
DS return code: '0001001908': 'U01001908 Line '1': attribute  ''Value'' :
closing quotation mark expected'. Error occurred in UCDSFUN at position:
'DS_MEMSV2XML10'.

I investigated the two VARA objects in the folder to see if there was anything peculiar with them. They looked fine. I tried again to export the folder, and this resulted in a different error:

Error: U04002032 Unable to export all objects. Further information is provided in the
client's report if SERVER_OPTIONS at position 12 has been set to N.

I enabled xml="2" tracing in the UCDJ config file and tried again. In the trace, I saw the large uc-env element containing the exported folder structure and objects. The following element appeared immediately after one of the JSCH objects in this portion of the trace.

<error>4002032
<messagebox>
      <message nr="4002032">
         <OK default="1">
            <command owneraction="close"/>
         </OK>
      </message>
   </messagebox>
</error>

I took at look at the relevant JSCH object. When I opened the object, another error appeared:

Error: U04005996 Wrong character or definition was found in the configuration variable UC_OBJECT_DOCU.

Next, I looked at the UC_OBJECT_DOCU object in client 0.

KeyValue 1
JSCHDocu,@Runbook@RunInfo

There was a comma missing between @Runbook and @RunInfo. I do not have any idea how this comma disappeared. I’m almost certain it was there before. Adding the comma fixed the problem:

KeyValue 1
JSCHDocu,@Runbook,@RunInfo

Outcomes