Julia_Buchner_9324

UNIX Agents crash due to spelling error in the INI file

Discussion created by Julia_Buchner_9324 on Dec 12, 2017
Latest reply on Jan 10, 2018 by Julia_Buchner_9324
An error often reported to Support lately is a Known Error of the Unix Agent in version 12.1.

The Unix agent crashes with two possible errors:
U00034036 There is no valid license for Agent' AGENT_NAME' (license class' 1', license category' Production', platform' EX. OS. UNX')
or
U00034018 The specified license class' 1' for Agent' AGENT_NAME' is less than the required license class
or
Unix Agent Error: [1]+ Segmentation fault ./ucxjlx6

However, when checking the license file, the License tab in the AWI Administration panel or the agent's INI configuration file, the license is correctly set. If you browse your Agent's log file, you will find these two contradictory lines:
20171117/180137.408 - license_class=V
[...]
[...]
20171117/180137.410 - License:' 1

This is linked to a spelling change, in the agent's INI file, from the license_class parameter (version 12.0 and lower) to license_Class (12.1 onwards). Normally, the agent should understand both configurations, but this is not the case.
The bug has been reported and will be fixed in following versions:
  • Automation Engine 12.2.0 - Released planned around 2018-06-19
  • Automation Engine 12.1.1 - Released planned around 2018-01-29
To correct this problem, just change the parameter in the INI file to the old license_class value and restart the agent to fix the problem.

Source: https://automic.force.com/support/apex/CommunityArticleDetail?id=ka30N000000H3jr.


Outcomes