AnsweredAssumed Answered

Problème de mail envoyé recalé sur le mailserver

Question asked by didierlasne612270 on Mar 6, 2018
Bonjour,

Nous somme en train de changer de mailserver sur l'environnement de pprod et j'ai un souci de mail non délivrés.
Le mail suivant, envoyé par un CALL est OK

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html><head>
<style type="text/css">
.c1 {
  background-color: #ECAC00;
  font-family: Arial, Helvetica, sans-serif;
  font-size: 0.8em;
  font-style: italic;
  padding: 2px 10px 2px 10px;
}
.c2 {
  background-color: #ECECEC;
  font-size: 0.8em;
  font-weight: bold;
  padding-left: 5px;
  padding-right: 5px;
}
.c3 {
  background-color: #B2B2B2;
  font-size: 1.5em;
  padding: 5px 5px 5px 5px;
  text-align: center;
}
</style>
</head>
<body>
<table style="border:1px solid #000000;box-shadow:8px 8px 8px #666;" cellspacing="0" cellpadding="0">
<tr><td class="c3">&ht</td></tr>
<tr>
<td style="padding:0;">     
<table border = "0" rules = "none" cellspacing="0" cellpadding="0" width="100%">
<colgroup width="120px"/>
<tr><td class="c1">&c1#</td><td class="c2">&$SYSTEM#</td></tr>
<tr><td class="c1">&c2#</td><td class="c2">&$CLIENT# (&$CLIENT_DESC#)</td></tr>
<tr><td class="c1">&c3#</td><td class="c2">&UC_CAUSE_NAME</td></tr>
<tr><td class="c1">&c4#</td><td class="c2">&UC_CAUSE_NR</td></tr>
<tr><td class="c1">&c5#</td><td class="c2">&statustext# (&UC_CAUSE_STATE)</td></tr>
<tr><td class="c1">&c6#</td><td class="c2">&UC_CAUSE_RETCODE</td></tr>
<tr><td class="c1">&c7#</td><td class="c2">&date# &time#</td></tr>
<tr><td class="c1">&c8#</td><td class="c2">&parentname#</td></tr>
<tr><td class="c1">&c9#</td><td class="c2">&parenttyp#</td></tr>
<tr><td class="c1">&ca#</td><td class="c2">&parentnr#</td></tr>
<tr><td class="c1">&cb#</td><td class="c2">&groupeSnow#</td></tr>
</table>
</td></tr>
<tr><td style="padding: 5px 5px 5px 5px;"align="center"><a href="http://www.automic.com"><img border="0" src="http://cdn2.hubspot.net/hub/241294/file-205974691-png/Images/Logos_&_Icons/Automic_logo.png" width="183" height="70" alt="UC4" /></a></td></tr>
</table>
</body>

On vois le content type dans le message original:

Content-Type: multipart/mixed; boundary="=uc4="

Depuis un CALL très similaire, nous avons un rejet

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html><head>
<style type="text/css">
table, tr, th, td {
    border: 1px solid black;
    border-collapse: collapse;
    padding: 2px 5px;
}
</style>
<title>Users</title>
</head>
<body>
<h1>Liste des objets désactivés au &JOUR#/&MOIS#/&ANNEE#</h1>
<h2> - Désactivés dans la définition l'objet (header)</h2>
<h2> - Désactivés dans un schedule</h2>
<h2> - Désactivés dans un workflow</h2>
<br><br>
<table border>
<tr>
</tr>
<tr><th align="center" BGCOLOR="#81daf5">Objet</th><th align="center" BGCOLOR="#81daf5">Type Objet</th><th align="center" BGCOLOR="#81daf5">Parent (JSCH, JOBP ou rien)</th><th align="center" BGCOLOR="#81daf5">Execution la plus ancienne</th><th align="center" BGCOLOR="#81daf5">Execution la plus recente</th>
<tr><td>&OBJ#</td><td>&PERE#</td><td>&TYPE#</td><td align="center">&ANCIEN#</td><td align="center">&RECENT#</td>
</tr></table>
</body>

la ligne <tr><td>&OBJ#</td><td>&PERE#</td><td>&TYPE#</td><td align="center">&ANCIEN#</td><td align="center">&RECENT#</td> est présente plusieurs fois avec des valeurs différentes en fonction du contenu d'un fichier .csv
Et sur le serveur de mail on vois une erreur de "duplicate content-type"

Content-type: text/html; charset=iso-8859-1


et il est effectivement présent deux fois à la suite

Est ce que ça évoque quelque chose à quelqu'un ?

Coté One Automation, je ne vois pas grand chose de paramétrable si ce n'est les quelques champ SMTP_ du UC_CLIENT_SETTINGS...

L'OS redhat utilise un postfix qui à un main.cf qui m'a l'air assez d'origine (sauf les modification faite sur les paramètres
smtp_use_tls, smtp_tls_security_level, smtp_tls_note_starttls_offer et smtp_tls_CAfile 

A noter qu'un envoi similaire passe depuis l'os en direct..

Merci d'avance
Didier

Outcomes