AnsweredAssumed Answered

UnknownHostException when recording as a gateway

Question asked by Benoit_B on Apr 16, 2018
Latest reply on Apr 17, 2018 by Benoit_B

Hello,

 

I'have the following error when recording, as a gateway, with the workstation :

 

2018-04-16 10:53:22,581Z (12:53) [HTTP-Proxy-Recorder:10025] ERROR System.err - java.net.UnknownHostException: myDomain.myCountry
2018-04-16 10:53:22,581Z (12:53) [HTTP-Proxy-Recorder:10025] ERROR System.err - at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:184)
2018-04-16 10:53:22,581Z (12:53) [HTTP-Proxy-Recorder:10025] ERROR System.err - at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:172)
2018-04-16 10:53:22,581Z (12:53) [HTTP-Proxy-Recorder:10025] ERROR System.err - at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
2018-04-16 10:53:22,582Z (12:53) [HTTP-Proxy-Recorder:10025] ERROR System.err - at java.net.Socket.connect(Socket.java:589)
2018-04-16 10:53:22,582Z (12:53) [HTTP-Proxy-Recorder:10025] ERROR System.err - at sun.security.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:668)
2018-04-16 10:53:22,582Z (12:53) [HTTP-Proxy-Recorder:10025] ERROR System.err - at sun.security.ssl.SSLSocketImpl.<init>(SSLSocketImpl.java:427)
2018-04-16 10:53:22,583Z (12:53) [HTTP-Proxy-Recorder:10025] ERROR System.err - at sun.security.ssl.SSLSocketFactoryImpl.createSocket(SSLSocketFactoryImpl.java:88)
2018-04-16 10:53:22,583Z (12:53) [HTTP-Proxy-Recorder:10025] ERROR System.err - at com.itko.lisa.web.tcpproxy.SSLFactoryImpl.createClientSocket(SSLFactoryImpl.java:397)
2018-04-16 10:53:22,583Z (12:53) [HTTP-Proxy-Recorder:10025] ERROR System.err - at com.itko.lisa.web.tcpproxy.DualSocketFactory.createClientSocket(DualSocketFactory.java:92)
2018-04-16 10:53:22,583Z (12:53) [HTTP-Proxy-Recorder:10025] ERROR System.err - at com.itko.lisa.web.tcpproxy.AbstractTCPProxyEngine.launchThreadPair(AbstractTCPProxyEngine.java:390)
2018-04-16 10:53:22,583Z (12:53) [HTTP-Proxy-Recorder:10025] ERROR System.err - at com.itko.lisa.web.tcpproxy.PortForwarderTCPProxyEngine.run(PortForwarderTCPProxyEngine.java:115)
2018-04-16 10:53:22,583Z (12:53) [HTTP-Proxy-Recorder:10025] ERROR System.err - at java.lang.Thread.run(Thread.java:745)

 

Using a browser, with system proxy, the domain is reachable.

I've tried to configure the system proxy in the workstation (in lisa.properties on my DevTest installation), but without success (the proxy is configured, but the error still present).

 

What can I do to have the domain reachable from DevTest ?

 

Thanks for the help.

 

Benoit

Outcomes