AnsweredAssumed Answered

"404 not found" error while sending request to REST api virtual service , method GET

Question asked by k12345 on Apr 19, 2018
Latest reply on Apr 19, 2018 by Rick.Brown

Hi,

 

I have created a virtual service using request response pairs for rest api , method id GET.  In Virtual service image operation name is populated as -

 

/api/retrieveId/{URLPARAM0} and arguments have parameter - URLPARAM0 with value 12.

 

When I try to send request to above virtual service through REST step -

 

http://hostname:port/api/retrieveId/{URLPARAM0} or http://hostname:port/api/retrieveId/12.

 

I am getting error - The requested URL was not found on this server. (404) which is unable to match stateless request.

 

I also tried by sending URLPARAM0 value in query parameters but no luck. Also when I tried by having only operation name as /api/retrieveId/ . I can receive response. So it means that URLPARAM0 value is not resolve during requestcall.

 

Can anybody suggest a way to call these GET REST api ? is there somethings needs to be chnaged while sending request ?

 

Outcomes