AnsweredAssumed Answered

GET_FILESYSTEM

Question asked by JeffMuller608908 on May 3, 2018
Latest reply on Aug 15, 2018 by talle01

I am testing our upgrade from v10 to v12.1.  The script below has worked in version 10 for years.  The script is  setting up a file transfer from a unix server to a z/os.  I am creating a vara object in the no folder (it is being created).  It is not being populated with the file name or the key.  I have corrected one of the issues thanks to help on this site yesterday.  I have read some on the "GET_FILESYSTEM" not working correctly on v11 and still not working on v12.  I don't understand it all but I do use it in our scripts.  Below is a partial part of one of our scripts.  Will this work or would this be part of our problem?  The script ends but never sees a file to pick up.  Thanks again.

 

! Check to see if the file exists on MVS before calling JOBF to transfer it
: SET &FILE_COUNT# = GET_FILESYSTEM(MVSTEST, &FILENAME#, PATH_FILE_COUNT)
: SET &FILE_COUNT# = FORMAT(&FILE_COUNT#)
: PRINT "This is the print statement with the value of file count: '&FILE_COUNT#'"
: IF &FILE_COUNT# > 0
: PRINT "Files found matching the pattern (&FILE_COUNT#), calling transfer script."

Outcomes