AnsweredAssumed Answered

Nimsoft CDM ignore bind mounts?

Question asked by RackerMatt on May 10, 2018
Latest reply on May 11, 2018 by DavidM

CA team,

 

Is there a way to have Nimsoft cdm ignore bind mounts? I understand cdm has the ability of ignoring filesystem types, however, with bind mounts in cdm.cfg, they are seen as ext4 off the local disk fs where the source directory of the bind mount exists. Linux "mount" sees the bind mount type as none and it would be handy if this could be incorporated.

 

<#var#sftp#site1#home#test>
active = yes
description = File system /var/sftp/site1/home/test
disk = /dev/mapper/vglocal20160707-root00

file_system_type = ext4

 

/var/sftp/test/home/test on /var/sftp/site1/home/test type none (rw,bind)
/var/sftp/test/home/test on /var/sftp/site2/home/test type none (rw,bind)

etc..

 

Current methods of mitigating this are

  • Setting active to no for all bind mounts.
    • Annoying as it requires manual intervention every time a bind mount is added to avoid any duplicate monitoring events.
  • Setting the <fixed_default> active to no once the initial setup has been done, before the bind mounts are added.
    • This is not the best route as clients add further storage (SAN/Local) and these need to be monitored without invention from an engineer.

 

Are there are any suggestible regex methods i can use? If not, could this be a feature request to be added to later versions of cdm?

 

Thanks,

 

Matthew

Outcomes