AnsweredAssumed Answered

error while restaring apache process

Question asked by kavin.singh.chauhan on Jul 4, 2018
Latest reply on Jul 4, 2018 by thama06

Hi All,

 

We are not able restart successfully apache process for SRP (secure reverse proxy) server.  Siteminder agent is installed on the server and it is acting as a secure reverse proxy server. Apache process is not coming up successfully. PFB the screenshot of apache process.
Server Details.
Red Hat Enterprise Linux Server release 6.9 (Santiago).

ps -eaf | grep httpd
root      1431     1  0 12:05 ?        00:00:00 /opt/app/srp1/bin/httpd -d /opt/app/srp1 -k start
nobody    1434  1431  0 12:05 ?        00:00:00 /opt/app/srp1/bin/httpd -d /opt/app/srp1 -k start
nobody    1654  1431  0 12:11 ?        00:00:00 [httpd] <defunct>
root      1656   840  0 12:11 pts/0    00:00:00 grep httpd

Below is error log.
[Thu Jun 28 12:05:27.034502 2018] [mpm_worker:notice] [pid 1186:tid 139988196591456] AH00295: caught SIGTERM, shutting down
[Thu Jun 28 12:05:56.192110 2018] [ssl:warn] [pid 1428:tid 140311754192736] AH01906: dev.wam-proxy.us.ericsson.net:443:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Thu Jun 28 12:05:56.192326 2018] [ssl:warn] [pid 1428:tid 140311754192736] AH01909: dev.wam-proxy.us.ericsson.net:443:0 server certificate does NOT include an ID which matches the server name
[Thu Jun 28 12:05:56.223052 2018] [ssl:warn] [pid 1431:tid 140311754192736] AH01906: dev.wam-proxy.us.ericsson.net:443:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Thu Jun 28 12:05:56.223074 2018] [ssl:warn] [pid 1431:tid 140311754192736] AH01909: dev.wam-proxy.us.ericsson.net:443:0 server certificate does NOT include an ID which matches the server name
[28/Jun/2018:12:05:56] [Info] [CA WebAgent LLAWP] [1435] [LLAWP Monitor: LLAWP has been started.]
[Thu Jun 28 12:06:01.247988 2018] [mpm_worker:notice] [pid 1431:tid 140311754192736] AH00292: Apache/2.4.12 (Unix) OpenSSL/1.0.1e-fips configured -- resuming normal operations
/opt/app/srp1/bin/httpd: symbol lookup error: /opt/app/srp1/bin/httpd: undefined symbol: apr_global_mutex_lockfile
[Thu Jun 28 12:06:01.248027 2018] [core:notice] [pid 1431:tid 140311754192736] AH00094: Command line: '/opt/app/srp1/bin/httpd -d /opt/app/srp1'
/opt/app/srp1/bin/httpd: symbol lookup error: /opt/app/srp1/bin/httpd: undefined symbol: apr_global_mutex_lockfile
/opt/app/srp1/bin/httpd: symbol lookup error: /opt/app/srp1/bin/httpd: undefined symbol: apr_global_mutex_lockfile

Could you please check and provide your inputs regarding the above error or guide us to resolve the issue?

 

Thanks,

Kavin

Outcomes