Patrick-Dussault

Tech Tip : CA Single Sign-On : SOA upgrade 

Discussion created by Patrick-Dussault Employee on Aug 3, 2018

Question:

 


We're planning to upgrade our SOA environment 12.1SP2 to 12.8 and we'd
like to know if the SOA Agent 12.1SP2 will work with the Policy Server
12.8 ?

 

Answer:

 


At first glance, this SOA Agent 12.1SP2 will be still supported with
your Policy Server 12.8, but we strongly recommend you to upgrade the
SOA Agents to the lastest version 12.52SP1CR09, referencing the EOS
document :

CA SOA Security Manager r12.1 (includes all Service Packs and
Cumulative Releases) End of Service Announcement

"While this particular End of Service does not cover these
components, no new certifications for r12.1 (including all Service
Packs and Cumulative Releases) for these components will be executed
after December 31, 2016.

CA SOA Security Manager Agent for Web Servers CA SOA Security Manager
Agent for Application Servers Upgrade Paths At this time we encourage
you to plan for your migration. The recommended no-charge software
upgrade option for customers running CA SOA Security Manager 12.1
should upgrade to either CA Web Services Security Manager 12.51 or the
more recent 12.52 release."

https://support.ca.com/us/product-content/status/announcement-documents/2017/ca-soa-security-manager-r12-1-end-of-service-announcement.html

Here's the link of the latest WSS Agent (former SOA Agent) :

Solution Document: SS04282
https://support.ca.com/us/download-center/solution-detail.html?docid=655786&os=ANY&aparno=SS04282

Its Support Matrix

CA SiteMinder Family of Products Informational Documentation Index

CA SiteMinder Web Services Security 12.52

https://support.ca.com/us/product-content/recommended-reading/technical-document-index/ca-siteminder-informational-documentation-index.html

Its documentation :

Install Agents

Web Services Security Agent for Apache-based Servers
Web Services Security Agent for IIS Servers
Web Services Security Agent for Oracle iPlanet Servers
Web Services Security Agent for Oracle WebLogic
Web Services Security Agent for IBM WebSphere

https://docops.ca.com/ca-single-sign-on/12-52-sp1/en/installing/install-agents

Note that you'll need to upgrade the SOA Policy Server 12.0SP2 to 12.8
in 2 phases :

1. Upgrade from 12.0SP2 to 12.52SP1;
2. Upgrate from 12.52SP1 to 12.8;

Ref.:

Parallel Upgrade

You can complete a parallel upgrade from Release 12.5x or later to
Release 12.8. For information about the components that are available
for upgrade, see Complete the Upgrade Prerequisites.

https://docops.ca.com/ca-single-sign-on/12-8/en

 

KB : KB000108531

Outcomes