AnsweredAssumed Answered

Introscope EM startup issue

Question asked by mzwetsloot on Aug 16, 2018
Latest reply on Aug 17, 2018 by mzwetsloot

I reinstalled Introscope Enterprise Manager on my W10 laptop, when starting the startup script is running for about 20 seconds and then it closes out again.

I had this issue also in my first installation and we found out that was due to access rights in C:\Program Files\CA APM\Introscope10.7.0.45\product\enterprisemanager\configuration\org.eclipse.osgi folder.

I now made sure the system and users have full access to this map.

 

When I check the IntroscopeEnterpriseManager.log file then I see some errors passing:

[Manager.AppMapSubsystem] APM Data model subsystem is unavailable so AppMap feature is not functional. Please check the DataBase connectivity or disable AppMap feature.

 

[Manager] The EM failed to start. Error activating bean: com.wily.introscope.server.beans.apm.ApmServiceBean (com.wily.introscope.server.beans.apm.ApmServiceBean)

 

[SpringOsgiExtenderThread-8] [Manager] Uncaught Exception in Enterprise Manager: In thread 'SpringOsgiExtenderThread-8' and the message is: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'eventMonitorDependentServices': FactoryBean threw exception on object creation; nested exception is org.springframework.osgi.service.ServiceUnavailableException: service matching filter=[(objectClass=com.wily.apm.em.monitor.isengard.IMonitorEventNotificationManagerDependencyHelper)] unavailable

 

Can someone assist in getting this fixed so I can run EM normally ?

Outcomes