AnsweredAssumed Answered

API Explorer requires secure HTTPS connection

Question asked by AgentIce99 on Aug 16, 2018
Latest reply on Aug 17, 2018 by AgentIce99

Hi,

 

I'm trying to test out adding some basic API's through the portal. I have two API's added, one running off my local IIS, and one running off a remote app server. I have two VM's running on my machine, one for the portal and one for the gateway. 

 

I am able to hit both API's through the gateway proxy (in my case, something like my.gateway:8443/api/helloworld).

 

However, when I add a definition file and go to the API Explorer and try to submit a a test operation, I keep getting the error "API Explorer requires secure HTTPS connections. Please ensure your API descriptor file uses only HTTPS."

 

I have tried modifying my swagger 2.0 file with no luck. I tried editing the No Auth Template under "API Portal Integration" so that it's not checking for SSL, no change.

 

I did manage to get it work with a WADL file that just points to the proxy url (which is HTTPS) and enabling SSL on the template options, is that what is expected? Here's the WADL file that worked:

 

<?xml version="1.0" encoding="UTF-8"?>
<application xmlns="http://wadl.dev.java.net/2009/02">
<doc xml:lang="en" title="ChallengeQuestions REST"/>
<resources base="https://my.gateway:8443/">
<resource path="api/identity" id="List ChallengeQuestions">
<doc xml:lang="en" title="List ChallengeQuestions"/>
<method name="GET" id="Get ChallengeQuestions List">
<doc xml:lang="en" title="Get ChallengeQuestions List"/>
<request/>
</method>
</resource>
</resources>
</application>

 

Thanks for any help,

Tom

Outcomes