AnsweredAssumed Answered

CA Directory 14 version installation issue

Question asked by VKSSO on Aug 30, 2018
Latest reply on Sep 5, 2018 by Alan Baugher

Hi,

 

I'm trying to install the CA Directory 14 version on RHEL7 server. Here are steps followed by me -

1. Downloaded the package from CA Site on my local machine in .zip file.

2. Copied the .zip file on Linux server and run unzip to get .iso files

3. Tried to mount .iso(for dxserver) on my linux box, but it was giving some error message -

[root@****** install]# mount -o loop /opt/DVD500000000001421.iso /opt/cadir/
mount: /dev/loop1 is write-protected, mounting read-only

4. I continued further with installation using by running ./dxsetup.sh from path /opt/cadir/linux_x86_64/dxserver/install

5. Got below error/warnings with DXserver Installation 

============================ DXSERVER INSTALLATION ============================

Installing DXserver software (as user dsa)
/opt/CA/Directory/dxserver/install/.dxcshrc: No such file or directory.

Stopping any existing DXservers, SSL daemons or DXadmind processes

=========================== CA OpenSSL INSTALLATION ===========================

Copying CAPKI libs
===================== DXSERVER INSTALLATION (CONTINUED) ======================

/opt/CA/Directory/dxserver/install/.dxcshrc: No such file or directory.
Setting up environment for account dsa...

DXserver has installed successfully

 

Even though the highlighted file exists, but it's marked as hidden.

 

Post installation, I'm trying to setup a new DSA but it says like dxnewdsa command not found. I tried to set DXHOME to /opt/CA/Directory/dxserver/install but no luck. Directory startup also have issue.

 

Please note - I'm doing the installation using root user. Did I miss any step or setting up something incorrectly?

 

Appreciate your help !

Outcomes