AnsweredAssumed Answered

Unix Command to delete entries along with sub entries in CA Directory

Question asked by DebSarkar on Sep 17, 2018
Latest reply on Sep 25, 2018 by SriRao

Hello Everyone,

 

Version of CA Directory is r12.0 SP12

We are trying to delete an entry with its sub-entries, We are trying to run dxdelete tool from /CADirectory/dxserver/bin to delete entries with subentries, but we are getting below error -- -bash-4.1$ dxdelete -v -h ip:port "smSessionId=gNELP/Q4CG0bQH0M3skLZ/T3v/Q\=,ou=sessionstore,dc=smsession,dc=com" ldap_initialize( ldap://10.118.209.73:30404 ) deleting entry "smSessionId=gNELP/Q4CG0bQH0M3skLZ/T3v/Q\=,ou=sessionstore,dc=smsession,dc=com" Delete Result: Operation not allowed on non-leaf (66) After that, we even tried to run LDAPDelete command, but still no luck. we are Getting the below error with ldapdelete command -- [XXXXX@******1 ~]$ ldapdelete -v -D cn=smadmin,ou=admin,dc=smsession,dc=com -w password -h op:port "smSessionId=gNELP/Q4CG0bQH0M3skLZ/T3v/Q\=,ou=sessionstore,dc=smsession,dc=com" ldap_initialize( ldap://10.118.209.73:30404 ) deleting entry "smSessionId=gNELP/Q4CG0bQH0M3skLZ/T3v/Q\=,ou=sessionstore,dc=smsession,dc=com" ldap_delete: Operation not allowed on non-leaf (66)

 

Even, I have tried using –r in ldapdelete, but it says invalid option.

Though I can find in CA communities, -r stands for

-r

Makes any delete operation recursive.

 

Can anyone please tell me the command to delete entries along with sub-entries from CA Directory?

 

Thanks. Regards!

Outcomes