ShayShabo610810

The character "%2" is omitted from URL

Discussion created by ShayShabo610810 on Oct 21, 2018

Hello everyone,

 

I am trying to run the following command (jobs win): 

start chrome= "http://bi/ReportServer/Pages/ReportViewer.aspx?%2fIT-DEV%2fYAIR%2fHOTdelevery70918&rs:Command=Render&ord_ID=3079912&rs:Format=PDF"

 

But the system lowers the character "%2" from the URL.

 

c:\>C:\Automic\Agents\Windows\bin\UCXJWX6M.EXE JNR=0075971155 MNR=0020 PNR=2300 IPA=192.168.55.162 TYP=S TXT="        Job started"  Program 'UC4 Job Messenger' version '12.2.0+build.1034' started UCMDJP: ********************************************************************* UCMDJP: ** JOB 0075971155 (ProcID:0000004532) START AT 21.10.2018/11:35:51 ** UCMDJP: **                                    UTC TIME 21.10.2018/08:35:51 ** UCMDJP: ** --------------------------------------------------------------- ** UCMDJP: **                                    USED:      0.000 CPU         ** UCMDJP: ********************************************************************* Program 'UC4 Job Messenger' version '12.2.0+build.1034' terminated normally  c:\>start chrome= "http://bi/ReportServer/Pages/ReportViewer.aspx?fIT-DEVfYAIRfHOTdelevery70918&rs:Command=Render&ord_ID=3079912&rs:Format=PDF" 

Anyone know a solution to the problem?
This site should download an automatic PDF file but I get an error:

 

Reporting Services Error


  • The path of the item 'fIT-DEVfYAIRfHOTdelevery70918' is not valid. The full path must be less than 260 characters long; other restrictions apply. If the report server is in native mode, the path must start with slash. (rsInvalidItemPath) Get Online Help

SQL Server Reporting Services

 

When I open the URL in chrome the PDF download automatically 

Outcomes