AnsweredAssumed Answered

[Solved] CA UIM 9.0.2 - Impossible to deploy wasp on SUSE 12 SP3 (without and with the cryptkey and certificate file copied from the primary hub)

Question asked by J-Gentilhomme on Nov 3, 2018
Latest reply on Nov 3, 2018 by J-Gentilhomme

Hi Everyone,

 

Since yesterday evening, I try to deploy in my LAB the new CA UIM GA available (9.0.2). For the primary hub, all appear to be good !

 

For the UMP .... I encoutner a problem : imposible to start a wasp probe.

 

Since the wasp 9.0.1, I familiar with the new "cryptkey" parameter. But in my case, I've folowed the instructions, and copied the certificate.pem file from the primary hub to my UMP server.

 

I've also tried to create my own certificate with the SSL command provided and deploy the .pem files (certificate + private key) on each components. I've tried with the cryptkey configured on the certificate.pem created. Nothing start on each servers (due to the uncapacity of the data_engine probe to provides the "get connection url").

 

Then, I've tried with a different certificate on each component ... without hope ! (but in that case it's a normal comportment)

 

For more detail :

- BDD : Windows 2012 R2 + MSSQL Enterprise 2017
- Primary HUB : Windows 2012 R2
- UMP 1 : Linux SLE 12 (SUSE) SP3 (<= I'm blocled to deploy the first UMP)
- UMP 2 : Linux SLE 12 (SUSE) SP3
- CABI : Linux SLE 12 (SUSE) SP3

 

=> All hardware and software requierment are ok !

 

We have CA UIM 8.5.1 which run perfectly on the same infrastructure components listed below (Same version in PROD, UAT and DEV environments).

 

Indirectly, it's have a real problem with the OpenSSL command provided, because, it's impossible to start the Primary hub with a certificate generated by this way ... The data_engine probe failed to provides a "get conection url" by the concerned pu callback.

Configure robot.cfg - CA Unified Infrastructure Management - 9.0.2 - CA Technologies Documentation 

 

Thank you for your help :-)

Outcomes