AnsweredAssumed Answered

Error U00000009 when attempting to quit a schedule (JSCH)

Question asked by Michael_Lowry on Feb 12, 2019
Latest reply on Feb 15, 2019 by jkessans

After successful deployment of a JSCH object to one of our AE systems, an automated process uses the QuitTask Java API class to quit and restart the schedule automatically, without user intervention. Several times in the past couple of days, we have seen a new problem related to this process.

 

For example, yesterday at 16:53 the program tried to quit the running JSCH with run ID 636959964.

The message returned by the Automation Engine was error U00000009, a message that one typically sees only when trying to manipulate objects or tasks to which one does not have authorization. And strangely, rather than quitting the already-running task, the Automation Engine appears to have tried to start a new task, the one with run ID 637429790. The details of this task reveal that this is where the error 9 appeared.

 

No tasks were running under the running JSCH task at the time. Has anyone else seen this behavior?

Outcomes