AnsweredAssumed Answered

Not all blocks (Limit '120') of file '...' have been transferred

Question asked by MatthiasSchelp on Mar 14, 2019
Latest reply on Apr 23, 2019 by MatthiasSchelp

Hello,

 

Today one of my colleagues suprised me with an unusual error. He had a script that does a simple PREP_PROCESS_FILE on a "big" xml file (> 1MB)

:SET &HND# = PREP_PROCESS_FILE(<agent>,"<xml file>")

 

When he ran that script, he received following error message (my original error is in german but I tried to guess how Automic would have translated it). So here we go ...

 

U00029007 Not all blocks (Limit '120') of file '...' have been transfered.

 

This reminded me of the error message you get, when a report is to big to be stored in the database. See this post by Iris Muttenthaler click. So I changed the the value of MAX_REPORT_SIZE for the specific agent to 480 and (suprisingly) it worked.

 

Maybe I'm just not getting it, but does anybody know why MAX_REPORT_SIZE affect PREP_PROCESS_FILE??? And can someone (maybe someone from Automic) explain if that is how it's supposed to work?

 

EDIT : Added that the xml has to be 1 MB or bigger with MAX_REPORT_SIZE = 120.

Outcomes