DhruvClarity

CA Clarity Intallation Problem: Running Install.bat

Discussion created by DhruvClarity on May 27, 2010
Latest reply on May 29, 2010 by another_martink
Hi,

We are trying to install Clarity in our sandbox. On running install.bat we are getting below mentioned problem. If anyone has faced this kind of issue previoulsy...or workaround do let me know.

-------------------------------------------------------------------------------------------------------------------------------------
Current Clarity Version = 7.5.3.3456 FP08 008
Planned Intermediate v8 = 8.1 SP5
Final Version = 12.0.6

Current Setup:
Database: MS SQL 2005 Enterprise Edition
OS: Windows 2003 on Vm Ware ESX 3.0
Application Server: Orion

Final Setup:
Database: MS SQL 2005 Enterprise Edition
OS: Windows 2003 on Vm Ware ESX 3.0
Application Server: Apache-tomcat-5.5.17

Can you also verify this plan?

-------------------------*** Output from CMD ***------------------------------------------------
Microsoft Windows [Version 5.2.3790]
(C) Copyright 1985-2003 Microsoft Corp.

C:\Documents and Settings\XDSHAH>path
PATH=C:\Program Files\Java\jdk1.5.0_11\bin;e:\Apps\clarity\bin;C:\Program Files\
Common Files\Actuate\7.0\JDK141\jre\bin\client;e:\apps\j2sdk1.4.2_13\bin;C:\WIND
OWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem

C:\Documents and Settings\XDSHAH>java -version
java version "1.5.0_11"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_11-b03)
Java HotSpot(TM) Client VM (build 1.5.0_11-b03, mixed mode, sharing)

E:\Apps\temp>install.bat
Buildfile: E:\Apps\temp\gateway.xml

gateway:
Trying to override old definition of task java

install:

Clarity Home Directory [E:\niku\clarity] : E:\Apps\clarity
-----------------------------------------
You chose the following:

install.dir = E:\Apps\clarity
-----------------------------------------

_upgrade:

Current version: 7.5.3.3546
Upgrading to: 8.1.5.4588
Your current version is 7.5.3.3546. This upgrade is only applicable to 8.1.0.42
47 and later versions. Please consult Niku Professional Services for assistance
with your upgrade path.

BUILD SUCCESSFUL
Total time: 34 seconds

E:\Apps\temp>


Also on “Gateway.xml” file we get following failure:

<project name="gateway" default="gateway" basedir=".">

<property name="target.ant.file" value="install.xml"/>

<target name="resume">
<property name="skip.completed" value="true"/>
<property name="force" value="true"/>
</target>
...
<target name="gateway">
<condition property="j2sdk.pass">
<contains string="${java.version}" substring="1.5"/>
</condition>
<fail unless="j2sdk.pass">

FAILURE: INCORRECT JAVA VERSION
------------------------------------------------------
You are running with Java version ${java.vm.version}.
Niku requires JDK 1.5 (Java 5.0). Please update
your JAVA_HOME setting to point to the correct j2sdk
directory and try again.
------------------------------------------------------
</fail>

<ant antfile="${target.ant.file}"/>
</target>
</project>

Please Suggest.

Thanks & Regards,
Dhruv_Clarity

Outcomes