ca.portal.admin

OLQ ISSUE

Discussion created by ca.portal.admin on Apr 7, 2008
Latest reply on Apr 8, 2008 by ca.portal.admin
Hello All:



I was asked by a client's user support group to provide them with a brief

training session of the IDMS database structure and tips for creating

OLQ reports. When I tried creating some sample OLQ reports using the MENU

Mode of OLQ, I noticed that some of the OLQ options were not available to

me. Thus, I was unable to create the desired OLQ reports.



One OLQ option that was not available from MENU mode is the option to ""

Alter database access strategy - Linkage"". This option is needed when

walking owners/members with multiple sets. For example, the PART-MASTER

and PROD-STRUCTURE records are connected via the following sets:



PART-COMPONENT

PART-WHERE-USED

PART-COMP-ITEM



When I initially create an OLQ report to obtain PART-MASTER and

PROD-STRUCTURE members, it appears that the PART-WHERE-USED set is selected

as the default in OLQ. I need to change the OLQ report to use the

PART-COMPONENT set. In the past, I used option ""Alter database access

strategy - Linkage"" to change the database strategy in OLQ. When I select

this option now, the list is empty. Below is what is displayed when I

select this option:





CA-OLQ *** Linkage Select

***

-> Page of

45000 Select relationship and press the ENTER key.



Selected Relationship Number

Relationships

Set Name Owner Name Member Name





Is this a Release 16.0 bug or is this option not allowed due to options

defined to my user id in the dictionary or the OLQ Statement in the SYSGEN?



As always any help would be appreciated.



The ACCESS is OLQSQL in the OLQ Statement in the System Generation and in my user id the ACCESS IS OLQSQL.



If I change it to IDMSSQL then it will NOT let me select any Subschema's, only Tables.



What happened to the Linkage Screen?



William M. Allen, Jr.

ARCH Consulting Associates, Ltd.

(704) 641-0296
"
IDMS Public Discussion Forum
IDMS-L@LISTSERV.IUASSN.COM
SMTP
IDMS-L@LISTSERV.IUASSN.COM
IDMS-L@LISTSERV.IUASSN.COM
SMTP








Normal

Normal
Re: OLQ ISSUE
"Hello All:

Thanks to Kay. Her solution QO68947 corrected the problem, but, the APAR as
I pulled it down from Support Connect would not apply, it said that is was
superseded, plus the documentation inside it says its for SP0 and SP1, we
are running SP3.

I ran an amblist on our 16.0 SP3 load library and it was not applied, so I
turned it into a straight super zap and applied it directly to the load
module then new copied it and it is working fine, we are now getting the
Linkage Section.

Bill Allen
(704) 641-0296

Outcomes