ca.portal.admin

2 more ""opportunities"" in release 17

Discussion created by ca.portal.admin on Apr 21, 2009
Latest reply on Apr 21, 2009 by ca.portal.admin
<soapbox>
I have adopted a new signature tag based on the events of this past
weekend - Sunday was fine - Monday all heck broke loose - due to lack of
application check-out testing after the upgrade on Sunday - several apps
were down most of Monday - due to things we could not have tested for in
testing environments, but could have been discovered Sunday had the apps
been tested Sunday </soapbox>


1) back for Y2K - our site wrote some ADS BIFs - the extended RHDCEVBF,
the XDE table, and the code itself - under 15 prod - the code program
was NOT sysgen'd and all worked well - under 17 - it needs to be
sysgen'd


2) we maintain 2 read-only CVs for handling all CICS read-only and much
CV2CV read only traffic - these are defined as CVs 73 and 75 (one on
each
LPAR) each with its own DMCL, its own SYSTEM number,, but a shared CV
NUMBER - this allows only 1 INTC module, one node for the resource
table
- the end result was - didn't matter what LPAR you were on - if you
wanted to get to CV75 - you would end up on a CV (either CV73 or 75,
both defined with CV NUMBER 75)

however in release 17 - the two-phase commit process requires a NODE for
CV73 (defined with CV# of 75) to complete the synchronization process -
as soon as we added this, everything worked great (did not need to
change the resource table nor relink any CICS programs)


Chris Hoelscher
Senior IDMS & DB2 Database Administrator Humana Inc
502-476-2538
choelscher@humana.com

you only need to test the programs that you want to work correctly




The information transmitted is intended only for the person or entity to
which it is addressed and may contain CONFIDENTIAL material. If you
receive this material/information in error, please contact the sender
and delete or destroy the material/information.
"
IDMS 3rd-party providers forum
IDMSVENDOR-L@LISTSERV.IUASSN.COM
SMTP
IDMSVENDOR-L@LISTSERV.IUASSN.COM
IDMSVENDOR-L@LISTSERV.IUASSN.COM
SMTP








Normal

Normal
"Re: 2 more ""opportunities"" in release 17"
"Chris,

I did not think 2 CV's on one LPAR could have the same Cvnumber, 2nd CV
would crash at startup, I have had this happen in 16.0 (and earlier
releases) on z/OS 1.9.

Steve

Outcomes