ca.portal.admin

Re:Re: [IDMSVENDOR-L] Strange thing in IDMS 17.0 SP1 DCLOG

Discussion created by ca.portal.admin on May 5, 2010
are you checking for ""both"" log full msgs?

DC050001
DC050004

i believe DC050004 is spit out when the log is 100% full - this message is
NOT checked by vanilla WTOexit

i have seen a log fill up so quicly due to a dump that the DC050001 is
never issues - only the DC050004 - and the vamilla wtoexit would never
catch it




Chris Hoelscher
IDMS/DB2 Database Architect
Humana Inc
502-476-2538
choelscher@humana.com

you only need to test the programs that you want to work correctly






From:
""William M. Allen, Jr."" <archcons@ARCHCONS.COM>
To:
IDMSVENDOR-L@LISTSERV.IUASSN.COM
Date:
05/05/2010 04:29 PM
Subject:
[IDMSVENDOR-L] Strange thing in IDMS 17.0 SP1 DCLOG
Sent by:
IDMS 3rd-party providers forum <IDMSVENDOR-L@LISTSERV.IUASSN.COM>



Hello All:



I just upgraded another Client to 17.0 SP1 and we are having a few issues;
one was with TSSMAI from Top Secret and there is a fix for that from CA.



The next issue is that the CV is not spitting out the log % full message
so
what is happening is that the log is filling up and the offload job is
never
getting submitted?



The exit is fine because it is submitting the Journal archive just fine.



The Messages for the Journal and log have the same destination and OS
route
codes, I have checked all of that. I have even restored and re-received
and
applied the startup user modification with no change.



The Log was formatted before we brought the CV up using IDMS 17.0 SP1
software.



We also had an issue with easy test causing system module program checks
near RHDCUXIT with all the tool kit exits installed. We have pulled all
the
exits from RHDCUXIT and easy test works fine. We still have to work with
the
vendors on a resolution for this one.



The last issue is the submission of the log archive, I know the exit is
working and the log has filled many times, but the IDMS Region is simply
not
issuing the log % full message?



And here is another strange thing when we view the log with LOGD we see
these system module program checks from four days ago and the log has
filled
at least five times since then because we have to archive it manually.



So my question is how does IDMS issue that log message, is there some sort
of header record in the log that might be corrupted?



We can always format the log but the Client is reluctant to do that
without
an explanation of why this is happening.



William M. Allen, Jr.

ARCH Consulting Associates, Ltd.

(704) 641-0296



The information transmitted is intended only for the person or entity to
which it is addressed and may contain CONFIDENTIAL material. If you
receive
this material/information in error, please contact the sender and delete
or
destroy the material/information.



The information transmitted is intended only for the person or entity to which it is addressed and may contain CONFIDENTIAL material. If you receive this material/information in error, please contact the sender and delete or destroy the material/information.
"
IDMS 3rd-party providers forum
IDMSVENDOR-L@LISTSERV.IUASSN.COM
SMTP
IDMSVENDOR-L@LISTSERV.IUASSN.COM
IDMSVENDOR-L@LISTSERV.IUASSN.COM
SMTP








Normal

Normal
Re: [IDMSVENDOR-L] Strange thing in IDMS 17.0 SP1 DCLOG
"rather than do a blanket format - why not clone it (for future use) and
format the prime dataset .....

Chris Hoelscher
IDMS/DB2 Database Architect
Humana Inc
502-476-2538
choelscher@humana.com

you only need to test the programs that you want to work correctly






From:
""William M. Allen, Jr."" <archcons@BELLSOUTH.NET>
To:
IDMSVENDOR-L@LISTSERV.IUASSN.COM
Date:
05/07/2010 09:14 AM
Subject:
Re: [IDMSVENDOR-L] Strange thing in IDMS 17.0 SP1 DCLOG
Sent by:
IDMS 3rd-party providers forum <IDMSVENDOR-L@LISTSERV.IUASSN.COM>



My WTOEXIT is hard included in the link edit of the startup. I have an
SMP/E
user modification that performs this function that I put together a long
time ago and it has worked on every release of IDMS including many 17.0
SP1
central versions with no problems whatsoever.

And at this site the WTOEXIT is getting executed and it is submitting the
journal jobs correctly as expected.

The problem is NOT with the WTOEXIT, the problem is that the CV is not
spitting out the log message showing what percentage full it is for the
WTOEXIT to intercept.

In my original E-mail I stated that we had all the tool kit exits and when
using a third party product called Easy Test we received system module
program checks near RHDCUXIT. As many of us know these exits all have to
do
with task analyzer and Master key so I personally believe that when we had
these issues the DCLOG somehow got corrupted and whatever the CV is
looking
at to issue these messages is corrupted and that is why we are not getting
the messages.

The client does not want to format the log until CA has a chance to
trouble
shoot this issue.

William M. Allen, Jr.
ARCH Consulting Associates, Ltd.
(704) 641-0296

Outcomes