ca.portal.admin

Re:INPLEN not documented in the manual

Discussion created by ca.portal.admin on May 17, 2010
Hello All:



For the assembly of #UCFBTCH there is a parameter called INPLEN where
you
can specify the columns for input parameters. Last night I upgraded an
account from 15.0 to 17.0 SP1 and the UCFBATCH program was failing
because
of sequence number in columns 73 thru 80.



I searched the manuals first and could not find anything; by chance I
looked
at the macro and saw the INPLEN parameter which defaulted to 80.



I added INPLEN to the assembly with INPLEN=72 and that corrected the
problem.



William M. Allen, Jr.

ARCH Consulting Associates, Ltd.

(704) 641-0296
"
IDMS Public Discussion Forum
IDMS-L@LISTSERV.IUASSN.COM
SMTP
IDMS-L@LISTSERV.IUASSN.COM
IDMS-L@LISTSERV.IUASSN.COM
SMTP








Normal

Normal
FW: INPLEN not documented in the manual
"William -=0D=0A=0D=0ADid your commands in the UCFBATCH job run all the way =
to col 72?=0D=0A=0D=0AI have also recently upgraded a region to R17, and ye=
s, the #UCFBTCH=0D=0Amacro did default to &INPLEN=3D80=2E However, when I =
ran a UCFBATCH job,=0D=0Awith sequence numbers in col 73-80, they don't cau=
se a problem unless my=0D=0ADCMT command runs all the way out to col 72=2E=
=0D=0A=0D=0AI'm very curious as to what your input looked like=2E=0D=0A=0D=
=0ATom Lindh - IDMS Database Systems Programmer=0D=0AFirst Data USA - GTO E=
nterprise Servers - z/OS Database Systems=0D=0AOffice#: 303 - 967 - 6136=0D=
=0ACell#: 720 - 810 - 5985=0D=0AFax#: 303 - 967 - 8228=0D=0A=0D=0A=0D=0A---=
Original Message---=0D=0AFrom: IDMS Public Discussion Forum [mailTo:IDM=
S-L@LISTSERV=2EIUASSN=2ECOM]=0D=0AOn Behalf Of William M=2E Allen, Jr=2E=0D=
=0ASent: Monday, May 17, 2010 8:47 AM=0D=0ATo: IDMS-L@LISTSERV=2EIUASSN=2EC=
OM=0D=0ASubject: INPLEN not documented in the manual=0D=0A=0D=0AHello All:=
=0D=0A=0D=0A=0D=0A=0D=0AFor the assembly of #UCFBTCH there is a parameter c=
alled INPLEN where=0D=0Ayou=0D=0Acan specify the columns for input paramete=
rs=2E Last night I upgraded an=0D=0Aaccount from 15=2E0 to 17=2E0 SP1 and t=
he UCFBATCH program was failing=0D=0Abecause=0D=0Aof sequence number in col=
umns 73 thru 80=2E=0D=0A=0D=0A=0D=0A=0D=0AI searched the manuals first and =
could not find anything; by chance I=0D=0Alooked=0D=0Aat the macro and saw =
the INPLEN parameter which defaulted to 80=2E=0D=0A=0D=0A=0D=0A=0D=0AI adde=
d INPLEN to the assembly with INPLEN=3D72 and that corrected the=0D=0Aprobl=
em=2E=0D=0A=0D=0A=0D=0A=0D=0AWilliam M=2E Allen, Jr=2E=0D=0A=0D=0AARCH Cons=
ulting Associates, Ltd=2E=0D=0A=0D=0A(704) 641-0296=0D=0A=0D=0A------------=
-----------------------------=0D=0AThe information in this message may be p=
roprietary and/or=0Aconfidential, and protected from disclosure=2E If the =
reader of this=0Amessage is not the intended recipient, or an employee or a=
gent=0Aresponsible for delivering this message to the intended recipient,=
=0Ayou are hereby notified that any dissemination, distribution or=0Acopyin=
g of this communication is strictly prohibited=2E If you have=0Areceived th=
is communication in error, please notify First Data=0Aimmediately by replyi=
ng to this message and deleting it from your=0Acomputer=2E
"
IDMS 3rd-party providers forum
IDMSVENDOR-L@LISTSERV.IUASSN.COM
SMTP
IDMSVENDOR-L@LISTSERV.IUASSN.COM
IDMSVENDOR-L@LISTSERV.IUASSN.COM
SMTP








Normal

Normal
FW: INPLEN not documented in the manual
"William -

Did your commands in the UCFBATCH job run all the way to col 72?

I have also recently upgraded a region to R17, and yes, the #UCFBTCH
macro did default to &INPLEN=80. However, when I ran a UCFBATCH job,
with sequence numbers in col 73-80, they don't cause a problem unless my
DCMT command runs all the way out to col 72.

I'm very curious as to what your input looked like.

Tom Lindh - IDMS Database Systems Programmer
First Data USA - GTO Enterprise Servers - z/OS Database Systems
Office#: 303 - 967 - 6136
Cell#: 720 - 810 - 5985
Fax#: 303 - 967 - 8228

Outcomes