ca.portal.admin

Re:Re: OLQ Select index set

Discussion created by ca.portal.admin on Aug 24, 2010
Sive,

Unfortunately you cannot use the system owned index in the where clause as
you would with a user owned set.
The good news, however, is that if you specify all the fields from the
index in the where clause OLQ should use the correct index, as long as the
where clause contains only equal signs.

My guess is that if you have an optional system-owned index, OLQ will not
choose that.

I do believe you can define LRFs and use the keyword or field-name-equal
syntax of the LRF to force use of specific indexes and sets.

Tommy Petersen
110 Cokesbury Rd
Room 542H
Lebanon, NJ 08833

Phone:
Internal 200 - 3699
External (908) 236-3699
Fax: (908) 236-3692




sibe.verbeek@NL.A
BNAMRO.COM
Sent by: IDMS To
Public Discussion IDMS-L@LISTSERV.IUASSN.COM
Forum cc
<IDMS-L@LISTSERV.
IUASSN.COM> Subject
Re: OLQ Select index set

08/23/2010 10:04
AM


Please respond to
IDMS Public
Discussion Forum
<IDMS-L@LISTSERV.
IUASSN.COM>






Christopher,


Your suggestions were very helpful in getting an idea why the SQL statement
did not work as hoped.

First you have to know we have not implemented the SQL option.
Our database is a non relational (network) database.
The OLQ Select statement is our first step using SQL in a IDMS environment.

I have tried to run UPDATE STATISTICS (IDMSBCF) but got an error message:

UPDATE STATISTICS FOR SCHEMA SXT00001 AREA VAF ;

Status = -4 SQLSTATE = 3F000 Messages follow:

DB002009 T603 C-4M6009: Schema SXT00001 names an unvalidated non-SQL
defined schema

I have to define a SQL schema which references the non-SQL schema.
To define the SQL schema we have to implement (and according to our
systemprogrammer pay for) the SQL option.

Thanks for your help.

Kind regards,
Sibe Verbeek
ABN Amro bank
The Netherlands
0031-030-2260591

Outcomes