AnsweredAssumed Answered

Global Search broken

Question asked by brecka on Jun 26, 2012
Latest reply on Jun 28, 2012 by another_martink
Hi,

my fresh installed r13 behaves a bit odd:

i tried to check if Global search is working -> uploaded some txt & doc files to Knowledge Store ( using admin user, with all priviledges ) .
I can open and read documents from Clarity , but global search is not working, result is always 0. I tried also run job "Index contents and documents for searches" but had no luck.

app-ca log contains
ERROR 2012-06-26 09:50:50,539 [http-8080-4] niku.dms (clarity:admin:5041022__79F3ABFE-A954-4544-BA97-EC8F19E15D46:dms.KSaddMultipleFileAction) error indexing file^M
com.niku.dms.util.DMSException: Could not create directory in file store.
(time & date is file upload time, not when job was executed)

- installed app uses filestore in database (MSSQL) - why should i get error "Could not create directory in file store when my filestore is in DB ?

-user niku is owner of searchindex dir:
drwxrwsrwx  3 niku niku  4096 Jun 21 14:30 searchindex
Regards,
Michal

Outcomes