AnsweredAssumed Answered

Clarity 13.0 Upgrade issues

Question asked by xoggernaut on Jul 6, 2012
Latest reply on Oct 1, 2012 by Chris_Hackett
Hello everyone,

Long story short, we have had issues upgrading Clarity 12.1 to Clarity 13.0.

Upgrade process finished well. The environment came up and we were able to login. Everything else worked, but the project object was on lockdown mode. Make any change to the project data and save, the edit just vanishes, no error message given and the page returned to the previous state looking as though nothing changed on the project. Even a minor change like appending a space to the description field of the project did not work.

When we reviewed the logs, they had the following message over and over:
ERROR 2012-03-19 17:06:20,882 [http-8043-1] lookup.LookupTypeCache
(clarity:claritysysadmin:29906228__C53B9CEB-03AD-4B95-B984-5A33D92C5E0D:main
nav.work)
Invalid lookup type: LOOKUP_SEC_BKPMGR
ERROR 2012-03-19 17:06:20,882 [http-8043-1] lookup.LookupControllerImpl
(clarity:claritysysadmin:29906228__C53B9CEB-03AD-4B95-B984-5A33D92C5E0D:main
nav.work)
Lookup: LOOKUP_SEC_BKPMGR doesn't exist

We checked version 12.1 production and did not find this lookup.

So, in a last ditch effort, I tried something else. A plain install of Clarity v13.0.1, let it run through completion to the CSA stage, where it just lets you install the CSA console and then you get on to CSA to perform db upgrade and xdm related post upgrade activities.

So, as per the plan, CSA got installed. Beacon and CSA are up at the moment. Went into the DB part and hit upgrade from NSA. It ran for a few minutes and it hit the wall with the following error:

Jul 6, 2012 1:36:09 PM Error executing command: db -javaHome E:\clarity\jdk1.6.0_20\jre core-upgrade
E:\clarity\clarity\.setup\scripts\db.xml:1580: The following error occurred while executing this line:
E:\clarity\clarity\.setup\scripts\db.xml:1756: ERROR: Upgrade failed. Please review the upgrade logs for details.

at org.apache.tools.ant.ProjectHelper.addLocationToBuildException(ProjectHelper.java:551)

at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:444)

at org.apache.tools.ant.taskdefs.CallTarget.execute(CallTarget.java:105)

at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:291)

at sun.reflect.GeneratedMethodAccessor5.invoke(Unknown Source)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

at java.lang.reflect.Method.invoke(Method.java:597)

at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)

at org.apache.tools.ant.Task.perform(Task.java:348)

I'm wondering if this last ditch approach really does not hold water becoz it's mapping apples to oranges? I am unsure. I'm still researching. In the meantime, has anyone upgraded a working version of v12.1 to v13.0 or v13.0.1 successfully? I am very interested in knowing your experiences. If any of you may have run into that missing lookup problem up there.

Your thoughts and ideas or even general discussion are most welcome. Our users are "really" amped about version 13, especially the part about the gantt chart being directly editable. And these roadblocks are causing some heartache.

Thanks, guys.

Outcomes