AnsweredAssumed Answered

Allocation XOG Errors

Question asked by AndreaMcV on Jul 23, 2012
Latest reply on Jul 24, 2012 by AndreaMcV
Hi,
We are trying to do some customizations using xog.
I have been testing using prj_projects_alloc_act_etc_read and have been getting errors when trying to swap out the resourceID. I have stripped down the results to just a single resource. This project has no baseline and the resource has no assignments.

ERROR 1:
However, when I run in the xog, I get the following error:

blah blah blah
Description>Project Object update failed</Description>
<Exception><![CDATA[
java.lang.Exception: Could not find match for teamMember with teamUid = mcveya for BaseLinesDetails for resource = .
blah blah blah

(This is the same error outlined on this post, but the suggestion did not make any difference.)

ERROR 2:
Additionally, when I try to draw out the project using the above xog, I get an error when trying to add a resourceID filter:

blah blah blah
<Description>Project Object read failed</Description>
<Exception><![CDATA[
java.sql.SQLException: [CA Clarity][SQLServer JDBC Driver][SQLServer]An expression of non-boolean type specified in a context where a condition is expected, near 'and'.


ERROR 3:
And just for more fun, when I try to bounce the script back in exactly as pulled, I get this error:

blah blah blah
<Description>[Error] :0:0: attribute "requirementName" has a bad value: the length of the value is 36, but the required maximum is 32.
</Description>
<Exception type="java.lang.Exception"><![CDATA[
java.lang.Exception: Invalid xml data

This one is especially interesting because the requirementName field has a length of 100 and the value is being run back in without any change!


We are running version 12.0.3 and from what I can see so far, the allocation / replace / baseline / assignment portion of the application is as buggy as anteater ****.
Lots of very weird behaviours.

Any ideas?

Thanks,
Andrea

Outcomes