AnsweredAssumed Answered

9.1 - SOAP Header Insertion - Need to turn off CorrelationID

Question asked by KingNick on Aug 7, 2012
Latest reply on Jun 1, 2017 by Hallett_German
Branched to a new discussion
I recently put a 9.1 WebLogic agent on some Oracle Service Bus JVM's and although cross-process tracing is completed turned off, somehow the agent keeps hijacking the SOAP headers and the requests are being rejected. Oddly, the documentation shows the following:

There are four agent configuration properties that control the handling of the correlation identifier on the client and the server.
With these properties, you can specify whether the identifier should be inserted into the SOAP header, the HTTP header, both header protocols, or not inserted at all.
These properties start with the standard agent prefix com.wily.introscope.agent:


The funny thing about that is the IntroscopeAgent.profile file has no mention of these settings. I've looked in the Agent.jar file as well and can't find this setting.

Additionally, the doc says regarding correlation identification:
Because most services use SOAP messaging, the correlation identifiers are inserted and read from SOAP headers by default.
In certain situations, however, you may prefer to pass the correlation identifier using HTTP headers.
For example, in rare cases, adding the correlation identifier to the SOAP header can cause the message to be rejected because the correlation ID changes the SOAP payload.


The above is exactly what is happening but I can't for the life of me figure out how to turn it off.

Please Help!

Thank you in advance.

Outcomes