AnsweredAssumed Answered

How to Enable JMX for Weblogic

Question asked by deepak.c on Aug 10, 2012
Latest reply on May 8, 2014 by Anand Yadav
[font=Verdana][font] Hi, We are using wily to pull out weblogic10 metrics but it is currently not showing JMX folder.

We have already tried setting,
introscope.agent.jmx.enable=true

introscope.agent.jmx.name.filter=ThreadPoolRuntime:ExecuteThreadIdleCount,ThreadPoolRuntime:ExecuteThreadTotalCount,ThreadPoolRuntime:HoggingThreadCount,ThreadPoolRuntime:PendingUserRequestCount,ThreadPoolRuntime:QueueLength,ThreadPoolRuntime:StandbyThreadCount

introscope.agent.wldf.enable=false/true - set both

But it is not showing up.

Here are our weblogic command line parameters
-javaagent:D:\bea10_MP2\wily8\Agent.jar
-Dcom.wily.introscope.agentProfile=D:\bea10_MP2\wily8\IntroscopeAgent.profile
-classpath "D:\bea10_MP2\wily8\WebAppSupport.jar;

We have similar configuration on the other server but it is working fine. Any advice? We may be possibly be missing something.

Thanks,
Deepak

Outcomes