AnsweredAssumed Answered

CA APM 9.1 errors on Jboss 5.1.0.GA

Question asked by harout on Aug 15, 2012
Latest reply on Aug 17, 2012 by harout
Hello,

I hope someone can help me. I am new to Introscope and I'm having trouble with an agent I installed on a JBoss 5.1.0GA platform. I looked through the other threads for JBoss on the message boards and moved the WebAppSupport.jar to the appropriate folder. I have the following entry in the run.bat:


rem =====================================================================
rem Enable Introscope
rem =====================================================================
set JAVA_OPTS=%JAVA_OPTS% -Djboss.modules.system.pkgs=org.jboss.byteman,com.wily,com.wily
set JAVA_OPTS= -javaagent:%JBOSS_HOME%\wily\Agent.jar -
Dcom.wily.introscope.agentProfile=%JBOSS_HOME%
\wily\core\config\IntroscopeAgent.profile %JAVA_OPTS%
rem=======================================================================


Not sure about the first line but the rest I got off the CA instructions for a JBoss install.

The errors I am getting are the following:

ERROR [org.jboss.kernel.plugins.dependency.AbstractKernelController] (main) Error installing to Instantiated: name=user:service=IntroscopeCustomService state=Described mode=Manual requiredState=Configured
java.lang.NoClassDefFoundError: com/wily/introscope/agent/service/IAgentService

Caused by: java.lang.ClassNotFoundException: com.wily.introscope.agent.service.IAgentService from BaseClassLoader@7981c4eb{VFSClassLoaderPolicy@36a75e9f{name=vfsfile:

ERROR [org.jboss.kernel.plugins.dependency.AbstractKernelController] (main) Error installing to Real: name=vfsfile:/D:/ProgramData/HP/ALM/jboss/server/default/deploy/introscope-jboss-service.xml state=PreReal mode=Manual requiredState=Real
org.jboss.deployers.spi.DeploymentException: Error deploying: user:service=IntroscopeCustomService

Can someone help me?

Thank you,
Harout

Outcomes