Sagi_Gabay

"Configure Correlation Attributes" is missing

Discussion created by Sagi_Gabay Employee on Sep 5, 2012
Latest reply on Sep 20, 2012 by glenda

Identity Manager's ver 12.6 Administration Guide , page 168 Under Create Correlation rules read:
Click System, Provisioning Configuration, Configure Correlation Attributes.

The task is missing from the System Manager's admin role definition of privileged tasks. Usually, modifying the admin role and adding the task is enough:
( Modify Admin Role -> System Manager -> Tasks tab -> lcoate the task under the System category -> Associate it with System Manager role and submit the change. Then it should appear in the menu. )

However, in this case you will not see this task in this list and therefore to solve this issue you will need to import an xml file that associates this task to the System Manager role.
Attached you can find such a file. However, you can not use the attached file for your purpose. It is provided as a guide line or an example for what you need to do.

What you need to do is:
1. Export your roles and tasks xml file (from management console -> environments -> click on environment -> roles and tasks -> export ).
2. Keep the original file, make another copy and rename the copy to ConfigurerCorrelationAttributes.xml
3. Edit the file and ensure the the following section appears at the top:

<?xml version="1.0" encoding="UTF-8"?>
<ims:ImsTemplate xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://imsenvironmentobjects/xsd imsconfig://schema/ImsEnvironmentObjects.xsd" xmlns:ims="http://imsenvironmentobjects/xsd" xmlns:imsrule="http://imsmemberrule/xsd" xmlns:imsscope="http://imsscoperule/xsd" xmlns:imschange="http://imschangeaction/xsd">


<ImsTask name="Configure Correlation Attributes" tasktype="ADMIN" category="System" application="IMS" tag="CorrelationAttributeConfiguration" action="MODIFY" object="NONE" system="true" auditable="false" provisionable="false" workflow="false" external="false" hidden="false" public="false" checkscope="false" scopesecurity="AllObjectsInScope" autosynch="OFF" autoaccountsynch="OFF" webservice="true" priority="8" category2="Provisioning Configuration" category3="" taskorder="10" categoryorder="90" category2order="10" category3order="0" automaticexecution="false">


<Tab tag="CorrelationAttributeTag" tabdefinition="CorrelationAttribute">



<PropertyDict name="Config">




<Property name="Hide">0</Property>




<Property name="Name">Correlation Attribute Configuration</Property>



</PropertyDict>


</Tab>


<PropertyDict name="Config"/>


<PropertyDict name="TabConfig"/>

</ImsTask>

4. Continue editing the file and ensure the following is at the bottom of the file:
</ims:ImsTemplate>

5. In between the sections of 3 and 4 above you need to paste the System Manager admin role defintion. You should copy it from your originally exported xml file (see the attached example) and place it in between the sections in 3 and 4 above.

6. Ensure to add the following <Task tag="CorrelationAttributeConfiguration"/> to the list of tasks of the System Manager admin role. Again, see the attached file as an example.

7. Make sure no other tasks, roles, screen or other elements than what's mentioned above is in your ConfigurerCorrelationAttributes.xml file.

8. Save your ConfigurerCorrelationAttributes.xml

9. From management console import your ConfigurerCorrelationAttributes.xml file. Click environments -> click on your environment -> roles and tasks -> import.

10. Restart your environment.

11. Login as System Manager. You should see the missing option under the System menu category.



Yours,

Sagi Gabay
CA Technologies.

Outcomes