Chris_Thomas

Run this on your IdM Report Server if you Can't view reports.

Discussion created by Chris_Thomas Employee on Dec 7, 2012
Latest reply on Mar 24, 2016 by Ashok kumar Muthu

For a very brief summary of the problem / solution, please watch this 3 min video[color]. [size]


If you'd just like to solve your problem without understanding it, simply download this zip file, copy the contents to your report server desktop and run Simplify.vbs out cmd prompt launched as administrator.[color]. [size]

 

The fact that the IdM tools directory publishes the 32 bit version of the registry manipulation ONLY, which is required for the report server regardless of the platform chosen, generates a plethora of support issues that could easily be avoided.

A VB scripted solution has been published onto MyCA communities forum in order to try to mitigate incoming volume on this topic until a more permanent solution is deployed. (possibly simply deploying the attached script into the ReportServerTools directory of IM, which would replace the existing registry scripts that don’t work on 64bit platform)

If you're getting an invalid database connection error when trying to view reports, I suggest you run the attached WSH script (as local Administrator on the Report Server) to correct your problem.

'Christopher Ryan Thomas; Unify and Simplify registry deployment for IdM report server. Set WshShell = CreateObject("WScript.Shell") OsType = WshShell.RegRead("HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Environment\PROCESSOR_ARCHITECTURE") If OsType = "x86" then wscript.echo "Windows 32bit system detected... Applying 32bit reg key value pair" WSHShell.RegWrite "HKLM\SOFTWARE\Business Objects\Suite 12.0\Crystal Reports\DatabaseOptions\MergeConnectionProperties", "Yes" elseif OsType = "AMD64" then wscript.echo "Windows 64bit system detected... Applying 64bit reg key value pair" WSHShell.RegWrite "HKLM\SOFTWARE\Wow6432Node\Business Objects\Suite 12.0\Crystal Reports\DatabaseOptions\MergeConnectionProperties", "Yes" end if 

Documentation is also incorrect!

@HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Business Objects\Suite 12.0\Crystal Reports

The above line should also include DatabaseOptions after Crystal Reports. Putting the MergeConnectionsProperties in the wrong location will result in the failure to view reports because it's unable to communicate with the database.

[color=#f30808][font=Comic Sans]If you're getting an invalid database connection error when trying to view reports, I suggest you run the attached WSH script (as local Administrator on the Report Server) to correct your problem.[size=11][color][size][font]

Please post with any questions or concerns.
Thank you.
Regards,

Chris Thomas
CA Technologies
Principal Support Engineer
IdentityMinder Reporting Expert
Tel: +1-631-342-4360
Chris.Thomas@ca.com

Outcomes