CA Privileged Identity Manager Linux版 CAWINのインストールに失敗する

Document created by Manabu_Taniguchi Employee on Jul 17, 2015
Version 1Show Document
  • View in full screen mode

文書番号: JTEC002150

製品名: CA Privileged Identity Manager Linux版 CAWINのインストールに失敗する

バージョン: 全バージョン

OS: Linux

 

◆ 内容

CA Privileged Identity Manager (以下 CA PIM) Linux版のインストール時にCAWINのインストールに失敗する。

 

◆ 詳細内容

CA PIMでは、文字コード変換のためにCAWINという共通コンポーネントがインストールされますが、Linux x64ではCAWINのインストールに32ビットのncurses OSライブラリがインストールされている必要があります。しかし、32ビットのncurses OSライブラリがインストールされているにもかかわらず、PIMのインストールログにCAWINのインストールに失敗した旨が記録され、CAWINが正常 に/opt/CA/SharedComponent/cai18nにインストールされない場合があります。

ログ内容:

32 bit ncurses library is not installed.
Reason: On a 64 bit system the 32 bit library libncurses is necessary.
Action: ¥Install the "ncurses" 32 bit package with version >= 5.

CAWINのインストールに失敗しました。

CAWINのインストール時には、32ビットのncurses OSライブラリが/usr/libに存在するかが確認され、存在しない場合にはCAWINのインストールが失敗します。例えば、RHEL6では32ビット のncurses OSライブラリは/libにインストールされるために、OSライブラリがインストールされているにもかかわらず、CAWINのインストールに失敗します。

回避策としては、PIMのインストール前に/libのncurses OSライブラリファイルを/usr/libにコピーするか、/usr/libにシンボリックリンクを作成してください。

例:
   # cp -p /lib/ libncurses.so.5.7 /usr/lib
   もしくは
   # ln -s /lib/libncurses.so.5.7 /usr/lib/libncurses.so.5

すでにPIMのインストールを行い、CAWINのインストールに失敗している場合には、上記回避策の内容を実施いただいた後に、以下の手順にて手動でCAWINをインストールしてください。

手順:
   # CAI18N_APP_NAME=eAC
   # export CAI18N_APP_NAME
   # <SEOSDIR>/data/CAWIN/CAI18N.Linux.sh

Attachments

    Outcomes