SOI Tech Tip:  Catalyst Container not starting any of the Connectors installed in this Container

Document created by Britta_Hoffner Employee on Feb 23, 2017
Version 1Show Document
  • View in full screen mode

We have published the technical document TEC1045619 with the step to resolve this situation.

 

Catalyst Container not starting any of the Connectors installed in this Container

 

Catalyst Container not starting any of the Connectors installed in this Container

Document ID:  TEC1045619
Last Modified Date:  02/23/2017
Show Technical Document Details

Problem:

The Catalyst Container Service is not starting any of the Connectors that are installed in this Container.

Environment:
Catalyst Container 3.4.1.167 UIM connector 3.7
Cause:

The Catalyst Container is locked due to a corrupted org.eclipse.osgi folder content.

The Catalyst\CatalystConnector\container\data\log\container.log file shows the following message:

 

Feb 22, 2017 10:04:34 AM org.apache.karaf.main.SimpleFileLock lock INFO: locking
Resolution:

 

stop the Catalyst Container Service

delete all files in the folder Catalyst\CatalystConnector\jsw\bin\activemq-data\localhost\KahaDB\

delete everything except the CORE folder in Catalyst\CatalystConnector\container\data folder

in case the Catalyst\CatalystConnector\container\data\cache\org.eclipse.osgi folder couldn´t be deleted due to a corruption rename that container\data\cache folder into container\cache_old

delete <hostname>_CA_00050-AlarmCache.ub cache file in folder Catalyst\CatalystConnector\container\data\Core

start the Catalyst Container Service

1 person found this helpful

Attachments

    Outcomes