Tech Tip: UIM - Admin Console is not working after upgrade from 8.4 SP2 to 8.5

Document created by danst04 Employee on Mar 13, 2017Last modified by danst04 Employee on Mar 13, 2017
Version 4Show Document
  • View in full screen mode

Document ID:  TEC1278388
Last Modified Date:  03/11/2017
Show Technical Document Details

 

Problem:

After upgrading from UIM 8.4 SP2 to version 8.5, the admin console is no longer working.

 

Environment:
- UIM 8.4 SP2
Cause:

The wasp probe on the primary hub would not get a port and at first we saw that port 80 was taken.

 


Mar 08 10:32:21:383 ERROR [wasp-engine-startStop-1, org.apache.catalina.core.ContainerBase] java.util.concurrent.ExecutionException: org.apache.catalina.LifecycleException: Failed to start component [StandardEngine[wasp-engine].StandardHost[localhost].StandardContext[]]
at java.util.concurrent.FutureTask.report(Unknown Source)

Caused by: java.lang.ClassNotFoundException: com.liferay.portal.kernel.bean.BeanLocator
at org.apache.catalina.loader.WebappClassLoaderBase.loadClass(WebappClassLoaderBase.java:1892)
at org.apache.catalina.loader.WebappClassLoaderBase.loadClass(WebappClassLoaderBase.java:1735)
... 20 more
Mar 08 10:32:32:008 ERROR [main, org.apache.catalina.core.ContainerBase] startInternal() A child container failed during start
Mar 08 10:32:32:008 ERROR [main, org.apache.catalina.core.ContainerBase] java.util.concurrent.ExecutionException: org.apache.catalina.LifecycleException: Failed to start component [StandardEngine[wasp-engine].StandardHost[localhost]]
Caused by: org.apache.catalina.LifecycleException: Failed to start component [StandardEngine[wasp-engine].StandardHost[localhost]]
Mar 08 10:32:32:009 ERROR [main, com.nimsoft.nimbus.probe.service.wasp.Probe] main() Fatal error!
Mar 08 10:32:32:009 ERROR [main, com.nimsoft.nimbus.probe.service.wasp.Probe] main()

 

Resolution:

Perform the following steps on the Primary hub:

 

1. Deactivate wasp
2. Rt-click and delete the wasp probe
3. Delete the wasp folder from the file system
4. Redeploy the following necessary packages for the adminconsoleapp:
    - wasp
    - mps
    - uimhome
    - adminconsoleapp
5. Activate wasp

 

Then wasp should obtain a port as well as the PID.

 

Hit the adminconsole url/link:

 

http://localhost/adminconsleapp and the Admin Console Sign In window should be displayed - you should then be able to login.

 

Note also that the address for Admin Console is now:

 

<UIM_Server_IP_Address>:<wasp_port>/adminconsoleapp

 

Note: The wasp port is set to 80 by default.

 

The service_host probe is no longer required.

 

If you have the service_host probe activated, you should Deactivate it.

 

Additional Information:

Note that in the UIM 8.47 Help docs and the community webcast, these changes were noted:

 

https://docops.ca.com/ca-unified-infrastructure-management/8-47/en/upgrading-release-notes/release-notes#ReleaseNotes-AdminConsoleRedesign

 

Help doc extract:
New Home Page Address

 

The address for Admin Console is now:

 

<UIM_Server_IP_Address>:<wasp_port>/adminconsoleapp

 

Note also that the uimserverpackages.zip is simply used during the install and contains all of the necessary packages.

UIM Server Packages for 8.5
http://nmscdn.nimsoft.com/CAUIM_8.5-GA/uimserverpackages.zip 

Note that it should be about 2.2 GB in size if it was downloaded completely

1 person found this helpful

Attachments

    Outcomes