Tech Tip: UIM - Alarm Enrichment probe in error state after reboot

Document created by danst04 Employee on Mar 13, 2017
Version 1Show Document
  • View in full screen mode

Document ID:  TEC1988786
Last Modified Date:  03/11/2017
Show Technical Document Details

Problem:

alarm_enrichment probe stops working after primary hub machine reboot.

Environment:
- UIM 8.47 - alarm_enrichment v8.42
Cause:

As per the Release Notes:
NAS 8.43 contains the following fixes:
- alarm_enrichment rule_config file corrupt at system reboot
- alarm2 retry logic improved
- timestamps in NAS_TRANSACTION_SUMMARY on the backend SQL database did not match the entries in the SQLite .db files

This release requires UIM 8.40 or higher. These fixes are included in UIM 8.5.

Resolution:

1. Download and deploy nas version 8.43.

    ftp://UIMuser:CnIa24uJ@ftp.ca.com/UIM_Probe_Hotfixes/nas_843.zipCnIa24uJ@ftp.ca.com/UIM_Probe_Hotfixes/nas_843.zip

2. Deactivate nas and AE

3. Add post_max_age to your hub.cfg under the hub section and set it to 60:

    Open the hub probe using raw configure in the hub section add a key called:

    post_max_age

    Give it a value of:

    60

    Save it then,

4. Restart the robot watcher service.

5. Make sure these settings exist in the nas.cfg as well:

       lower_memory_usage_threshold_percentage = 0.90

       upper_memory_usage_threshold_percentage = 0.90

       memory_usage_exceeded_threshold = 1

 

6. Reboot the machine when possible and check to see if the alarm_enrichment probe activates with no issue.

1 person found this helpful

Attachments

    Outcomes