Tech Tips: What Versions of DevTest are compatible with TLSv1.2?

Document created by MarcyNunns Employee on May 18, 2017
Version 1Show Document
  • View in full screen mode

Question:

Is TLSv1.2 compatible with DevTest?

 

Environment:

All Supported DevTest releases and platforms.

 

Answer:

TLSv1.2 was not enabled in Java 7 until update 95. So if you have DevTest 8.0.0 through 8.5.0, enabling TSLv1.2 will be an issue unless you are able to use Java 7 u95, which unfortunately, is no longer available for download from Oracle. Those earlier versions of DevTest did not have the required Java delivered with the product to use TLSv1.2.

DevTest 9.0.0 and later will not be a problem since those versions are delivered with Java 8 and TLSv1.2 is enabled by default.

You specify to use TLSv1.2 by putting the below property in the local.properties file of where your DevTest components run:

https.protocols=TLSv1.2

 

KB: TEC1617438

Attachments

    Outcomes