AnsweredAssumed Answered

XOG'ing error GEL vs GUI

Question asked by beekerc2 on Oct 12, 2010
Latest reply on Jun 30, 2011 by marlon.mckenzie
I'm in the process of creating GEL script that runs as an automated process when a project is created.   Among the things it does, is creates several sequential records in one sub-object, the creates sequential records in a different sub-object, then sets some custom attirbutes, etc.  I wrote the GEL script to create the XML to XOG in the first set of sub-object records.This stage worked perfectly.I then took that same code and modified it to create XML to XOG in the secon dset of sub-object records.Here's where I run into trouble.    here's the resultant XML code that the GEL script creates and submits to XOG.  





9
9




 and here's the error it generates










9


FATAL
com.niku.union.odf.exception.ODFServiceException: <?xml version="1.0" encoding="UTF-8"?>
<insertService type="xbl" componentId="odf" description="custom/customInsertService.xbl" transaction="dbTransaction" xmlns="http://schemas.niku.com/2002/objectTypes"/>







 Now the funny thing is if i take that piece of XML code and paste it in to the XOG client in the GUI, it works perfectly.  Any thoughts?ThanksB

Outcomes