Nika_Hadzhikidi

Tuesday Tip: Service error 1067 after upgrading JDK to new location

Discussion created by Nika_Hadzhikidi Employee on Apr 16, 2013
Latest reply on Apr 18, 2013 by Chris_Hackett
[size=5]After upgrading the JDK while installing into a new directory, and setting the correct JAVA_HOME and PATH environmental variables, Service error 1067 is thrown when trying to start the services.

Technical details:
You should make sure that in properties.xml file, the parameter <java_home> is pointing to the correct new java home directory. When starting the services, the value for <java_home> from the properties.xml file will be used in combination with PATH environmental variable in order to actually deploy the service.

The actual service wrapper will not use the JAVA_HOME variable at all.
JAVA_HOME is not used when starting the services, only PATH and <java home> from $CLARITY_HOME/config/ properties.xml will be.
Only reason for JAVA_HOME environmental variable to be defined is to as it is commonly put into the PATH too (and used for the schedulers on the client workstations), but it is not directly looked at or used when deploying the services.

Solution:
1.
Correct the $CLARITY_HOME/config/ properties.xml parameter for <java home> to point to the correct location
2.
Save
3.
Restart the services (make sure you actually restart them with Services applet or command niku start *** from the command prompt as this will force the services to redeploy)[size]

Outcomes