AnsweredAssumed Answered

13.2 Restore Fails

Question asked by Robert Ensinger on Feb 17, 2014
Latest reply on Feb 17, 2014 by Robert Ensinger

Hi folks.

I have a failed 13.2 --> 13.3 upgrade in a sandbox. No worries, for as per my usual routine I ran a backup of my 13.2 installation before my upgrade attempt with the admin backup command - let's restore!

I removed all servcies, my DBA team has restored my database and I've rolled back to 13.2's JVM & tomcat.

1) When I execute the admin restore command, the build fails with "java.lang.NoClassDefFoundError: net/sf/saxon/sort/Sortable" error (attached). The Sortable.class is in the saxon.jar in the %NIKU_HOME%/lib folder. Is the retore failing to pickup the classpath properly? Anyone seen this before and/or have a quick idea of something I've missed? (I've tried this with 13.2's and 13.3s JDK - same error each time.)

2) As a second question why bother with using the admin backup utility? What does it add? Why not just remove all services and copy the clarity folder? Right now, it's not a value add when I've put all my eggs in that basket and the basket fails to execute.

Attachments

Outcomes