AnsweredAssumed Answered

People Soft Agent

Question asked by Burt.Wiebe on Jun 10, 2011
Latest reply on Jun 21, 2011 by Lucy_zhang
I am testing the plugin for PS agent on R11.3.
I have no sql or database experience.

I have the PS plugin installed and when running a 'sqr report' it fails because the databasename is not being passed to the job.
in the job it shows -CD is blank instead of the database name PS91D1
in the Agentparm.txt I have coded
ps.db.url=jdbc:sqlserver://10.2.201.999:9999;DatabaseName=PS91D1

is ther another way to pass the database name?

I've tried using the DB_URL command but ESP flags this command as invalid.

I have tried this on both CA EE wlm 5.5 and CA EE wlm R11.3

Thanks in advance

Burt

I found a Tech Doc that solves this issue BUT In SQL Server on NT, there is no requirement for a PSDBOWNER table like there is in DB2 and Oracle.

So has any one had any issues/user issues after adding a PSDBOWNER table?




Tech Document
Title: sqr processes are failing to run. The problem is the database name is not being filled in.

Description:
For some reason our sqr processes are failing to run. The problem is the database name is not being filled in.
Sample command is
pssqr -CT ORACLE -CS %SERVER% -CD %DBNAME% -CA %ACCESSID% -CAP %ACCESSPSWD%
-RP ECOUT001 -I 302581 -R ECOUT001 -CO PRODUSER -OT 6 -OP %LOG/OUTPUT
DIRECTORY% -OF 2 -LG ENG
The %DBNAME% is not being filled in so it sees it as -CA
(SQR 5716) Unknown flag on command line: -CA
SQR for PeopleSoft: Program Aborting.
PeopleTools 8 - PSSQR
Copyright (c) 1988-2007 PeopleSoft, Inc.
All Rights Reserved
Solution:
In peoplesoft_log.txt it shows that the query below didn't return value:
SELECT DBNAME FROM PSDBOWNER
This Peoplesoft database was missing a link for the dbowner table. It is not in the sysadm schema. This needs to be fixed.


Thanks
Burt

Outcomes