AnsweredAssumed Answered

XOG-3250: Portlet record has not been inserted

Question asked by FloGoya on Feb 5, 2015
Latest reply on Feb 9, 2015 by FloGoya

Hello Friends,

 

I've noticed a behaviour I cannot fully understand when trying to read a portlet throught XOG.

 

I'm attaching the xml files so (if you want to) you can take a look at them.

 

I attempted to read the portlet in two ways:

 

One way I tried was using the export option on portlet list. It created the xml write file with the portlet details. But when I want to call to this xml throught XOG I recevied an error message on the command promtp and I got disconnected from XOG.

 

Second attempt was using the content pack xml filtering only for the portlet I wanted to extract. This is not working as expected since it is reading all the information from the content pack no matter if I set a filter. So when I wanted to xog it in the destiny environment ended with error XOG-3250: Portlet record has not been inserted. I once hit this same error and was because the xml was huge. So That time I resolved the problem by manually cleaning the writing xml file so only the portlet I wanted to transfer was in it. I don't find this very useful. Every time I need to move a portlet I need to clean all the xml file, I don't think it is working as it should.

 

I opened a ticket with support and the engineer suggested to increase the -Xmx parameter. He suggested to double my current value and to try again to xog in the xml, and if it fails again, double it once more... and so on.

 

I don't think this workaround is advisable, because when I want to move a portlet from one environment to another  I mean to move it from DEV to PROD, for instance, and if I'm taking all the content pack  might be moving configuration which is in DEV to PROD and that might not be ready to be taken to PROD.

 

I appreciate if anyone could let me know if they have hit this same behaviour, if someone apply this increment that CA support has suggested and if it's OK.

 

Thanks a lot!!

Flo

 

 

 

Attachments Descriptions:

 

osde_nuevo56_W.xml is the write file created through XOG

osde_nuevo56_R.xml is the read file

osde_nuevo_56_OUT.xml is the output with error XOG-3250

error from cmd.txt is the error I get in command prompt when trying to xog in the xml file created by the export option on the portlet list.

 

Message was edited by: Florencia Goya

Outcomes