KBarker

Using the LuaXml extension with the NAS environment

Discussion created by KBarker on Jul 10, 2010
Latest reply on Jul 14, 2010 by KBarker

Running Nimsoft nas on a Windows server.

 

I have some code that uses the LuaXml package to parse and generate configuration files for a program that opens an incident in a back-end incident managment system.

 

In order to install the LuaXml package in the right directories I had to discern the contents of the LUA_PATH environment variable.

 

It is "?:scripts/?".  Therefore, I though I should be able to load the luaXml.lua extension in either the home directory of my script or the Nimsoft scripts directory with the name "luaXml" (without any file extension).  I tried it first in the scripts directory and the lua extension successfully loaded but since the extension then does a require on the LuaXML_lib dll, that was not found.

 

I then put the LuaXML_lib dll into the scripts directory and that failed.  I then tried renaming the LuaXML_lib.dll file to NOT have the file extension but then lua assumes that the file is a lua script file and generates the error 

 

 

Error - error loading module 'LuaXML_lib' from file 'scripts/LuaXML_lib':

scripts/LuaXML_lib:1: '=' expected near ''

 

It is not clear to me how to access this dll -- or worse yet, is it possible to load this dll with the nas lua environment so that I can use the luaxml library?

Outcomes