AnsweredAssumed Answered

Help creating a Nimsoft Probe in LUA

Question asked by paul.thomas.1 on Sep 23, 2014
Latest reply on Sep 24, 2014 by paul.thomas.1

Hi all, 

 

I’m looking for some pointers in creating a probe in LUA.

 

I have already created a windows probe running VB, but this LUA one, running on Linux is proving rather painful!

 

After failing dismally to get my LUA script to run as a probe (it runs fine from the command line, as standard LUA). I used the code wizard to create something simply to use the logging facility:

 

probe.log(0,"Exiting program");

  

This is saved as filename.lua

 

When creating the probe, the lua ‘file’ properties has a type of binary (Yes, I have tried most of the others too!)

 

The ‘probe definition’ is of the timed type. With 'command' of /opt/usr/lua and 'argument' of filename.lua

 

Deploying the probe reports the following in both probe and controller logs:

 

Controller: Timed probe probe-name returned error code 1/0

 

 I have tried various methods -  for example, having the 'command' of filename.lua (and no arguments) produces the following:

 

Controller: Timed probe probe-name returned error code 255/0

  

Unfortunately, the code wizard documentation does not appear to contain any LUA examples.

 

Any advice is much appreciated.

 

Best regards,

Paul

Outcomes