AnsweredAssumed Answered

Websphere config for Windows ..

Question asked by andy.erskine on May 7, 2015
Latest reply on May 8, 2015 by Hiko_Davis
Branched to a new discussion

Looking at config for a Windows env Websphere instance - the docs state :

 

  1. Open the WebSphere Administrator Console.
  2. Navigate to Application Servers > your server > Server Infrastructure > Java and Process Management > Process Definition > Java Virtual Machine.
  3. Set the Generic JVM Argument field as follows:
    -javaagent:<PathToAgentJar> -Dcom.wily.introscope.agentProfile=<PathToAgentProfile> 

    where the PathToAgentJar and PathToAgentProfile depend upon the JVM in your environment:

    For IBM JVM 1.5 or 1.6, use AgentNoRedefNoRetrans.jar and IntroscopeAgent.NoRedef.profile
    For all other JVMs including IBM 1.7, use Agent.jar and IntroscopeAgent.profile

    For example, on JVM 1.7 the generic JVM argument field is as follows:

    For example, on JVM 1.7 the generic JVM argument field is as follows:

    -javaagent:<Agent_Home>/Agent.jar -Dcom.wily.introscope.agentProfile=<Agent_Home>/core/config/IntroscopeAgent.profile 
  4. Restart the WebSphere application server.

 

I have changed the JVM arguments to the following but its incorrect as websphere does not start - what should the correct syntax be here pls ?

 

I have :

 

-javaagent:E:\apm\Agent.jar -Dcom.wily.introscope.agentProfile=E:\apm\core\IntroscopeAgent.websphere.profile

and

Classpath:
E:\apm\common
\WebAppSupport.jar


APM9.7 java 1.7

Thanks.

Outcomes