AnsweredAssumed Answered

No Client Certificate was present

Question asked by StPaulPete on Oct 29, 2015
Latest reply on Nov 4, 2015 by StPaulPete


I can't seem to get my gateway to use client authentication.  The first assertion in my service is "Require SSL or TLS Transport with Client Certificate Authentication", with all client auth options set to required.  All I can get back is "No Client Certificate was present in the request.".  I have the listener in use set to client authentication "optional" (I tried "required" and it doesn't even get to the service.).  I have the TLS version set to use 1.1 or 1.2.

 

Not trusting my SOAPUI client to provide a certificate I tried hitting my service with a browser.  When I use the browser (Google Chome) to access a web site I know requires client auth it gives me a message asking to select my cert for client authentication.  No such message when I go after my gateway.  This is primarily why I don't think the gateway is send the request for client authentication as it should.

 

Anyone have any ideas I haven't already tried?

Outcomes