AnsweredAssumed Answered

How to configure SSL settings for IBM MQ in LISA 7.5.2

Question asked by san_crazy on Apr 5, 2016
Latest reply on Apr 6, 2016 by Kevin.Bowman

Hi,

I have  a requirement where i need to publish a message on to the IBM MQ which is SSL enabled.

From Dev team I got the SSL folder which contains .ks,ts.kdb.sth etc... files

Below are the settings I have done

In advance tab i have  given values for SSL Certstore "SSL folder path"

                                                                SSL CipherSuite : RC4_SHA_US

                                                                SSL Peername : CN=TADNT

1. Placed the MQserver keystore(xxxxxxx.ks) and truststore(yyyyyyyyy.ts) into local directory say ( In LISA_HOME - C:/LISA/Lisa7.5.2)

2. In LISA lisa.properties, added the following lines:

     javax.net.ssl.keyStore=C:/LISA/Lisa7.5.2/xxxxxxx.ks

     javax.net.ssl.keyStorePassword=<password>

     javax.net.ssl.trustStore=C:/LISA/Lisa7.5.2/yyyyyyyyy.ks     

     javax.net.ssl.trustStorePassword=<password>

3. Go to %LISA_HOME%/jre/bin in command prompt, run the below command (make sure your LISA installation folder is updated as your installed path) and provide the source and destination password.

     keytool -v -importkeystore -srckeystore C:\LISA\v7.2\jre\lib\security\cacerts -destkeystore C:\LISA\Lisa7.5.2\yyyyyyyyy.ts

 

For above command also I got success message from command prompt that is  certs imported sucess with 0 errors

After all this settings done, I tried to publish a message but it returns an error reason code 2  2042 and some times it returns 2009

Let me know if  any details required from my end to support me.

Outcomes